av在线>学习电脑>电脑硬件知识>外接设备>《如何在多层交换中实现网络的冗余的方法是什么》正文

如何在多层交换中实现网络的冗余的方法是什么

时间:2018-10-30 17:09:17本文内容及图片来源于读者投稿,如有侵权请联系[email protected] 加城 我要投稿

  像网桥那样,交换机将局域网分为多个冲突域,每个冲突域都是有独立的宽带,因此大大提高了局域网的带宽。这篇文章主要为大家介绍了如何在多层交换中实现网络的冗余的方法,网络冗余是工业网络的一项保障策略。作为快速反应备份系统,网络冗余的目的是减轻意外中断的风险,通过即时响应保证生产连续,从而降低关键数据流上任意一点失效所带来的影响,需要的朋友可以参考下

如何在多层交换中实现网络的冗余的方法是什么

  实验步骤:

  一、配置路由器:

  1. 在路由器1上配置路由器各个接口的IP地址:E0/0模拟的是外网的接口,e0/1和e0/2模拟的是内网接口的IP地址:配置E0/0外网的接口是为了NAT地址转换,r1(config)#interface e0/0

  r1(config-if)#ip add 100.100.1.1 255.255.255.0r1(config-if)#no sh

  r1(config-if)#ex

  r1(config)#interface e0/1

  r1(config-if)#ip add 10.1.1.2 255.255.255.0r1(config-if)#no sh

  r1(config-if)#ex

  r1(config)#interface e0/2

  r1(config-if)#ip add 10.1.2.2 255.255.255.0r1(config-if)#no sh

  r1(config-if)#ex

  2. 在路由器1上启动OSPF宣告网络的进程号,并为路由器1配置默认路由;配置默认路由的原因是因为我们在这里用路由器来模拟的公网所以要来配置默认路由:

  r1(config)#router ospf 100

  r1(config-router)#network 10.1.1.0 0.0.0.255 area 0r1(config-router)#network 10.1.2.0 0.0.0.255 area 0r1(config-router)#network 100.100.100.0 0.0.0.255 area 0r1(config)#ip route 0.0.0.0 0.0.0.0 e0/0

  二、配置交换机:

  (1)、配置交换机的VTP协议:

  VTP协议和工作原理:保持VLAN配置的一致性提供从一个交换机在整个管理域中的增加虚拟区域网的方法。在这里要注意的是:VTP域和VTP通告:

  VTP的运行模式:服务器模式(SERVER)、客户机模式(CLLENT)、透明模式(TRANSPARENT);VTP的三种消息通告:来自客户机的通告请求、汇总通告、子集通告:

  2 在sw-3L1配置VTP并制定模式为SERVER以及在它的上面创建VLAN。配置VTP的具体优点如下:

  在SW-3L1上换分VLAN的原因是因为SW-3L1是服务器模式;通过VTP来让不同的交换机学习;sw-3L1(vlan)#vtp domain benet

  sw-3L1(vlan)#vtp server

  sw-3L1(vlan)#vlan 20

  VLAN 20 added:

  Name: VLAN0020

  sw-3L1(vlan)#vlan 30

  VLAN 30 added:

  Name: VLAN0030

  3. 在sw-3L2上配置VTP指定它的模式为SERVER;在一个网络中可以配置多个SERVER所以.我们在这里所定义的是两个服务器;sw-3L2(vlan)#vtp domain benet

  sw-3L2(vlan)#vtp server

  4. 在sw-2L1上配置VTP指定它的模式为CLIENT;sw-2L1(vlan)#vtp domain benet

  sw-2L1(vlan)#vtp client

  5. 在sw-2L2上配置VTP指定它的模式为CLIENT;sw-2L2(vlan)#vtp domain benet

  sw-2L2(vlan)#vtp client

  (2)、配置交换机的TRUNK链路:

  1.在Sw-3L1上配置TRUNK;

  sw-3L1(config)#interface range f0/1 - 2

  sw-3L1(config-if-range)#sw mo tr

  sw-3L1(config-if-range)#no sh

  sw-3L1(config-if-range)#ex

  sw-3L1(config)#interface range f0/13 - 14sw-3L1(config-if-range)#sw mo tr

  sw-3L1(config-if-range)#no sh

  2.在sw-3L2配置TRUNK;

  sw-3L2(config)#interface range f0/1 - 2

  sw-3L2(config-if-range)#sw mo tr

  sw-3L2(config-if-range)#no sh

  sw-3L2(config-if-range)#exit

  sw-3L2(config)#interface range f0/13 - 14sw-3L2(config-if-range)#sw mo tr

  sw-3L2(config-if-range)#no sh

  sw-3L2(config-if-range)#ex

  3.在sw-2L1上配置TRUNK;

  sw-2L1(config)#interface range f0/13 - 14sw-2L1(config-if-range)#sw mo tr

  sw-2L1(config-if-range)#no sh

  sw-2L1(config-if-range)#ex

  4.在sw-2L2上配置TRUNK;

  sw-2L2(config)#interface range f0/13 - 14sw-2L2(config-if-range)#sw mo tr

  sw-2L2(config-if-range)#no sh

  (3)、配置STP生成树协议;首先要知道配置生成树的原因就是要实现网络的冗余。

  STP的概述:叫做生成树协议,就是把一个环形的结构变成一个树形的结构。他是通过一种算法将物理上存在的环形网络,通过一种算法,在逻辑上断开一些端口,来生成一个逻辑上的树形结构;STP的原理:虽然STP生成树的算法很复杂,但是它步骤可以归纳为一下三种:选择根网桥、选择根端口、选择指定端口;选择跟网桥:首先是选择根网桥的网桥ID,如果网桥的IP相同则选择优先级,优先级小的它则是根网桥,在优先级相同的情况下则选择MAC地址小的为根网桥。

  选择根端口:先是选择网桥的根路径成本,直连是网桥ID最小,端口ID最小!

  选择指定端口:根路径成本较低所在的交换机的网桥的ID的值较小,端口ID的值较小。

  BPDU(协议数据单元):交换机之间通过BPDU来交换网桥的ID、根路径成本等信息。它有两种类型:一种是配置BPDU、一种是拓扑变更通告;生成树端口有五种状态:禁用、阻塞、侦听、学习、转发。

  配置以太网通道:主要的原因是希望两条链路能够实现负载均衡,来提高链路带宽,以及相互备份。但是参与以太网捆绑技术有一下几个要求:虽然参于以太网隧道可以能提高链路带宽并运行一种机制,将多个以太网端口捆绑成一条逻辑链路。它最多可以捆绑8条物理链路,如果参于捆绑的端口必须属于同一个VLAN。如果一边是中继模式,那么两边必须要相同;1.在sw-3L1上配置vlan 20的根网桥;sw-3L2上配置30的根网桥:

  sw-3L1(config)#spanning-tree vlan 20 priority 4096sw-3L1(config)#spanning-tree vlan 30 priority 8192sw-3L2(config)#spanning-tree vlan 30 priority 4096sw-3L2(config)#spanning-tree vlan 20 priority 81922.在三层交换上配置以太网隧道;

  sw-3L1(config)#interface range f0/1 - 2

  sw-3L1(config-if-range)#channel-group 1 mode .

  sw-3L2(config)#interface range f0/1 - 2

  sw-3L2(config-if-range)#channel-group 1 mode

  (4)、在三层交换上配置接口以及各Vlan的IP地址并用OSPF宣告;首先我们要知道什么是三层交换技术?

  三层交换机技术简单的说就是二层交换技术+三层转发技术;而且是为了解决路由器和交换机的瓶颈问题;对于三层交换来说它的性能比较好;三层交换技术在第三层实现了数据包的高速转发,从而解决了传统路由器的低速、复杂所造成的网络瓶颈的问题;三层交换采用传统的MLS技术和基于CEF的MLS技术进行。

  1.配置三层交换接口的IP地址:

  sw-3L1(config)#interface f0/15

  sw-3L1(config-if)#no switchport

  sw-3L1(config-if)#ip add 10.1.1.1 255.255.255.0sw-3L1(config-if)#no sh

  sw-3L1(config-if)#ex

  sw-3L2(config)#interface f0/15

  sw-3L2(config-if)#no switchport

  sw-3L2(config-if)#ip add 10.1.2.1 255.255.255.0sw-3L2(config-if)#no sh

  sw-3L2(config-if)#ex

  2.配置三层交换上各个VLAN的IP地址;配置VLAN的IP地址相当于配置单臂路由的子接口的IP地址;sw-3L1(config)#interface vlan 20

  sw-3L1(config-if)#ip add 192.168.2.1 255.255.255.0sw-3L1(config-if)#no sh

  sw-3L1(config-if)#ex

  sw-3L1(config)#interface vlan 30

  sw-3L1(config-if)#ip add 192.168.3.1 255.255.255.0sw-3L1(config-if)#no sh

  sw-3L1(config-if)#ex

  sw-3L2(config)#interface vlan 20

  sw-3L2(config-if)#ip add 192.168.2.2 255.255.255.0sw-3L2(config-if)#no sh

  sw-3L2(config-if)#ex

  sw-3L2(config)#interface vlan 30

  sw-3L2(config-if)#ip add 192.168.3.2 255.255.255.0sw-3L2(config-if)#no sh

  sw-3L2(config-if)#ex

  3.在三层交换上宣告OSPF进程;(我们在这里把三层交换看成了路由器,所以在它的上面配置了OSPF协议)sw-3L1(config)#router ospf 100

  sw-3L1(config-router)#network 10.1.1.0 0.0.0.255 area 0sw-3L1(config-router)#network 192.168.1.0 0.0.0.255 area 0sw-3L1(config-router)#network 192.168.2.0 0.0.0.255 area 0sw-3L2(config)#router ospf 100

  sw-3L2(config-router)#network 192.168.2.0 0.0.0.255 area 0sw-3L2(config-router)#network 192.168.3.0 0.0.0.255 area 0sw-3L2(config-router)#network 10.1.2.0 0.0.0.255sw-3L2(config-router)#network 10.1.2.0 0.0.0.255 area 0(5)、在二层交换上划分指定的端口到不同的VLAN;sw-2L1(config)#interface f0/15

  sw-2L1(config-if)#sw mo acc

  sw-2L1(config-if)#sw acc vlan 20

  sw-2L1(config-if)#no sh

  sw-2L2(config)#interface f0/15

  sw-2L2(config-if)#sw mo acc

  sw-2L2(config-if)#sw acc vlan 30

  sw-2L2(config-if)#no sh


多层交换相关文章:

1.NAPT如何实现与三层交换机对接

2.tp450g路由器怎么设置与三层交换机对接

3.在三层交换机配置DHCP的方法

4.多台三层交换VLAN间相互通信配置方法是什么

5.路由器多网段NAT实现与三层交换机对接怎么设置

Copyright @ 2006 - 2018 av在线 All Rights Reserved

av在线 版权所有 粤ICP备15032933号-1

我们采用的作品包括内容和图片全部来源于网络用户和读者投稿,我们不确定投稿用户享有完全著作权,根据《信息网络传播权保护条例》,如果侵犯了您的权利,请联系:[email protected],我站将及时删除。

av在线 av在线

回到顶部